郑州站
全国热线电话:0371-53761661 15838399303
 当前位置:首页 > 网站技术文档
 网站技术文档
微信小程序要求服务器TLS版本大于等于1.2
2018-4-19 15:53:20    作者:missile

首先声明下,我自己的服务器是windowsserver2008R2的。

微信小程序与第三方服务器通讯的域名5个必要条件 
1、一个已备案的域名,不是localhost、也不是127.0.0.1,域名不能加端口 
2、加ssl证书,也就是https://~~~ 
4、HTTPS 服务器的 TLS 版本支持1.2及以下版本,一般就是1.0、1.1、1.2要同时支持这三个版本,一个也不能少,要不然就会出现下面这种情况 

5、微信小程序后台加上合法域名设置(一个月内改的次数是有限的,且行且珍惜)

现在说下TLS版本的问题,这个也是很多朋友经常掉的坑,我也掉过,然后直接去微软官网查了一下资料发现windows服务器系统的2008R2以下都不支持,所以大家xp、20003系统什么的就不用折腾了,没用的~~ 
发一个windows对TLS版支持的状况图表 

现在说下TLS版本的问题,这个也是很多朋友经常掉的坑,我也掉过,然后直接去微软官网查了一下资料发现windows服务器系统的2008R2以下都不支持,所以大家xp、20003系统什么的就不用折腾了,没用的~~ 
发一个windows对TLS版支持的状况图表 

选择best按钮,发现工具自动选择中了1.0 1.1 1.2版本,然后点击”apply“,一瞬间就完事了,然后他会提醒你,需要自己重启服务起才能生效,工具不会帮你重启。

Tianxiaxian Network Technology All Rights Reserved.